Scheduled downtime for O365 Go-live (RB CR# CHG0040910)

Incident Report for RB EmpowerID Cloud

Postmortem

Scheduled downtime for O365 Go-live (RB CR# CHG0040910)

Posted Aug 04, 2020 - 21:31 BST

Resolved

Scheduled downtime for O365 Go-live (RB CR# CHG0040910)
Posted Jul 25, 2020 - 19:30 BST